Oddjobd fails to start [FIXED]

I was configuring a new CentOS 6.5 machine to accept Active Directory logins and up until recently you could use the trust pam_mkhomedir.so to auto create home directories on login. This has since been replaced by a new system called Oddjobd and after the standard authconfig tool I enabled the auto create home directories and then Oddjobd fails to start.


[root@host ~]# service oddjobd start
Starting oddjobd:                                          [ FAILED ]

I did a bit of searching and couldn’t find anything in the logs on the machine or on the net with regards to this. So here is the post. Oddjobd requires access to the system message bus (dbus) and when trying to login to the machine with an AD account I got an error message.


org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

This pointed out that the message bus wasn’t working or was broken. So first thing I did was check the status of the messagebus and it wasn’t running. I started up messagebus service and then oddjobd started fine.


[root@host ~]# service messagebus restart
Stopping system message bus:                             [ FAILED ]
Starting system message bus:                               [ OK ]
[root@host ~]# service oddjobd start
Starting oddjobd:                                                      [ OK ]
[root@host ~]#

I was then able to login with my AD user and it auto created the home directory as required .